Every time I update my Hackintosh (P5WDH mobo) with the latest version of Mac OS I lose USB 2.0 speeds (all ports go to 1.1 speeds) and my system refuses to completely shutdown. The fix:

Delete AppleHPET.kext from /System/Library/Extensions

USB is flying and my systems sleeps and shuts down!

Quick and dirty:
Using Finder, copy the Kext to the desktop or somewhere as a backup (or you can use OSX86Tools too). Better be safe than sorry!
sudo rm -r /System/Library/Extensions/AppleHPET.kext


Tagged with:  

22 Responses to Slow USB and Shutdown Problems on Hackintosh After System Update

  1. CITmAn says:

    AWESOME! You rock! I was trying to figure this out. THANK YOU!!!

  2. DJ Krypton says:

    Hey! that’s great! I had such problem, and i couldn’t find a right solution! but this way worked great for me! It was so importaint, cause i have alot of external HDDs. My mobo is asus P5w64pro, system 10.5.8

    Thanx!!!

  3. Davisco says:

    Thank you so much.
    not only has usb speed increased, but also editing stuff in itunes has become faster.

  4. Charl Botha says:

    Whoohoo thanks!

    Before this fix, Disk Utility was taking 2 hours to write a 3.8 G image to USB stick, now it’s down to about 10 minutes.

  5. AMG says:

    On 10.6 reporting works thanks dude you are amzing

    this is for google

    slow USB and unresponsive USB ports and no USB2 connection on 10.6 snow leopard and shutdown errors

  6. Mike Waldron says:

    This hack still works with 10.6!?! Wowza. My little hack still running 10.5.8 like a champ.

  7. balli says:

    man thanks works like a charm, before my laptop didnt shut down and i didnt know it was still running and i just put it in the bag and it would heat up, then i noticed this and googled it with no help found ur post and works like a charm keep up the good work.

  8. Warren says:

    Dude, saved me a ton of time – this was bugging me forever, and my iPad syncs were slow!

    Thanks for the fix!

  9. […] figured it was time to figure out the root of the problem. A quick google search brought me to this site, and what proved to be a quick and easy fix to my problem. If you are too lazy to click through, […]

  10. Tisha says:

    That’s the best asnewr of all time! JMHO

  11. sotmax says:

    Yep it works…. 10.6.6

  12. Mario says:

    Hola gracias por la info, pero aparte de no haberme funcionado ahora le cuesta apagarse 5 minutos y otros 5 encenderse.

    He intentado copiar el archivo a su ubicacion original y me dice que turutu jejejej vammos que no se puede copiar a dicha carpeta

    10.6.5
    Placa asus p5k

    Gracias de todas maneras

  13. Dmitry says:

    cd ~/Desktop
    sudo -s
    mv /System/Library/Extensions/AppleHPET.kext .
    rm -rf /System/Library/Extensions.mkext
    rm -rf /System/Library/Extensions/Caches/ && rm -rf /System/Library/Caches/update_dyld_shared_cache -debug -force -root /
    defaults write /Library/Preferences/com.apple.windowserver Compositor -dict deferredUpdates 0
    reboot

    go to bios and enable hiSpeed mode for usb > F10
    result = 0
    echi don’t watched
    reboot
    go to bios and change to FullSpeed mode > F10
    result = 0
    usb watched but with low speed writing.

    summary: result 0

  14. the Enyel says:

    Hi there, tricky done and USB are right working under 10.6.3, i still have the shutdown/restart issues since this machine hangs when it should switch off…. any other chance to fix this issue??

    Thx!

  15. […] Delete AppleHPET.kext (this is frequently a problematic kext when it comes to customac builds). Ironically, I first found this fix way back in Leopard to fix slow USB speeds. […]

  16. p5gc mx 1333 says:

    […] too). Better be safe than sorry! sudo rm -r /System/Library/Extensions/AppleHPET.kext fond heree : http://blog.waldrondigital.com/2009/…dated-to-1057/ Tweet !function(d,s,id){var […]

  17. Jaybeatsz says:

    I freaking loveeeeeeeee uuuuuui

  18. anonymous says:

    please tell me how to open the system/library/extension and delta it

  19. […] Well after days of searching I found a out how to fix. By using SR Tools, I disabled AppleHPET.kext and all is well. Now I just need to see if I can get the 3.0 working. Source: http://blog.waldrondigital.com/2009/…dated-to-1057/ […]

  20. Crispossa says:

    It works!

  21. Mihin says:

    It works!

    Thank U 🙂

  22. Stepan says:

    Thank you Mike! Work on my ASUS P5PL2-e.
    Hi-Speed Bus detected!

Leave a Reply

Your email address will not be published. Required fields are marked *

Web Hosting