I recently purchased a new home, and with it a new Asus RT-AC68U router, and two gen 2 Nest learning thermostats.  I’ve been fighting Nest offline/disconnection issues with my Nest thermostats since I got installed them, and finally found the answer after hour and hours of Googling.  This fix should work with any Asus router, such as the dark knight RT-N66U, RT-AC66U, even if you use the Merlin firmware (which I use).  I will note that in attempting to fix this I also assigned my Nest thermostats DHCP static assignments, but that didn’t help with disconnects.  Oddly in my previous residence I had a Linksys E2500 and a single gen 1 thermostat and never had this issue.

I spent an hour+ on the phone with Nest level 1 and level 2 support and they didn’t really have an answer, but led me to narrow down my options.

Even with my previous fix below, my Nests still disconnected all the time.  I kept reading forums, etc., and now have the following settings, which seem to be working:

DTIM: 3
Beacon Interval: 211
Enable WMM APSD: Enable

Seems to be working.  We’ll see long term.  Lots of people are having issues with 4.3.3 and 4.3.2 and WiFi disconnects.

UPDATE: 3/11/15

Unfortunately, my thermostats still go offline intermittently.  I really wish Nest would get their s**t together.  My thermostat is wired with power.  This issue is seriously annoying, and is pervasive.

They mentioned that WMM sometimes creates issues, and I immediately gravitated to “WMM APSD” in the “Professional” tab of 2.4GHz.  I disabled this feature and I have not had a drop off since.

Set the following parameters in your “Wireless”, “Advanced” section for 2.4Ghz:

“Enable WMM APSD” and select “Disable”

For the record I also have “b/g protection” in “General” off as well, but I’m not sure that has anything to do with it.

 


Web Hosting